import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^.+?\\s)(.+)";
final String string = "Apple Macbook Pro\n"
+ "Apple Iphone 12\n"
+ "Samsung Galaxy S21 Silver";
final String subst = "Бренд : $1 \\nМодель: $2\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}