const regex = /(^.+?\s)(.+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^.+?\\s)(.+)', 'gm')
const str = `Apple Macbook Pro
Apple Iphone 12
Samsung Galaxy S21 Silver`;
const subst = `Бренд : $1 \nМодель: $2\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);