use strict;
my $str = 'Apple Macbook Pro
Apple Iphone 12
Samsung Galaxy S21 Silver';
my $regex = qr/(^.+?\s)(.+)/mp;
my $subst = 'Бренд : $1 \\nМодель: $2\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";