re = /(^.+?\s)(.+)/m
str = 'Apple Macbook Pro
Apple Iphone 12
Samsung Galaxy S21 Silver'
subst = 'Бренд : $1 \\nМодель: $2\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result