// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(^.+?\s)(.+)").unwrap();
let string = "Apple Macbook Pro
Apple Iphone 12
Samsung Galaxy S21 Silver";
let substitution = "Бренд : $1 \\nМодель: $2\\n";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}