# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/%%%\[emoticon.*]%%%/Emoticon/gm;t' <<< "%%%[emoticon name|https://example.org/name.jpg|67|45|/emoticon_report/name/]%%%
Michel
%%%[emoticon name|https://blabla/]%%%
"