using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"%%%\[emoticon.*]%%%";
string substitution = @"Emoticon";
string input = @"%%%[emoticon name|https://example.org/name.jpg|67|45|/emoticon_report/name/]%%%
Michel
%%%[emoticon name|https://blabla/]%%%
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}