re = /%%%\[emoticon.*]%%%/m
str = '%%%[emoticon name|https://example.org/name.jpg|67|45|/emoticon_report/name/]%%%
Michel
%%%[emoticon name|https://blabla/]%%%
'
subst = 'Emoticon'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result