const regex = /%%%\[emoticon.*]%%%/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('%%%\\[emoticon.*]%%%', 'gm')
const str = `%%%[emoticon name|https://example.org/name.jpg|67|45|/emoticon_report/name/]%%%
Michel
%%%[emoticon name|https://blabla/]%%%
`;
const subst = `Emoticon`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);