#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)%%%\[emoticon.*]%%%"
Local $sString = "%%%[emoticon name|https://example.org/name.jpg|67|45|/emoticon_report/name/]%%%" & @CRLF & _
"Michel" & @CRLF & _
"%%%[emoticon name|https://blabla/]%%%" & @CRLF & _
""
Local $sSubst = "Emoticon"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)