// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)%%%\[emoticon.*]%%%").unwrap();
let string = "%%%[emoticon name|https://example.org/name.jpg|67|45|/emoticon_report/name/]%%%
Michel
%%%[emoticon name|https://blabla/]%%%
";
let substitution = "Emoticon";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}