package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)%%%\[emoticon.*]%%%`)
var str = `%%%[emoticon name|https://example.org/name.jpg|67|45|/emoticon_report/name/]%%%
Michel
%%%[emoticon name|https://blabla/]%%%
`
var substitution = "Emoticon"
fmt.Println(re.ReplaceAllString(str, substitution))
}