#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i)(?:[^.]+\.){4}"
Local $sString = "12345.001.chris_comp.NY.2023_08_22.xlsx"
Local $sSubst = "$&USA."
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)