import re
regex = re.compile(r"(?:[^.]+\.){4}", flags=re.IGNORECASE)
test_str = "12345.001.chris_comp.NY.2023_08_22.xlsx"
subst = "$&USA."
result = regex.sub(subst, test_str)
if result:
print(result)