import Foundation
let pattern = #"(?:[^.]+\.){4}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"12345.001.chris_comp.NY.2023_08_22.xlsx"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$&USA."#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)