// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(?:[^.]+\.){4}").unwrap();
let string = "12345.001.chris_comp.NY.2023_08_22.xlsx";
let substitution = "$&USA.";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}