re = /(?:[^.]+\.){4}/i
str = '12345.001.chris_comp.NY.2023_08_22.xlsx'
subst = '$&USA.'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result