using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:[^.]+\.){4}";
string substitution = @"$&USA.";
string input = @"12345.001.chris_comp.NY.2023_08_22.xlsx";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}