use strict;
my $str = '12345.001.chris_comp.NY.2023_08_22.xlsx';
my $regex = qr/(?:[^.]+\.){4}/ip;
my $subst = '$&USA.';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";