package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(?:[^.]+\.){4}`)
var str = `12345.001.chris_comp.NY.2023_08_22.xlsx`
var substitution = "$&USA."
fmt.Println(re.ReplaceAllString(str, substitution))
}