$re = '/(?:[^.]+\.){4}/i';
$str = '12345.001.chris_comp.NY.2023_08_22.xlsx';
$subst = "$&USA.";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;