# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\.city\.).*?(\.checked)\]/$1poolavailable$2/gm;t' <<< ".city.playground[?(@.playhouse == 'true' && @.IsPoolAvailable=='true')].checked]
"