using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\.city\.).*?(\.checked)\]";
string substitution = @"$1poolavailable$2";
string input = @".city.playground[?(@.playhouse == 'true' && @.IsPoolAvailable=='true')].checked]
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}