// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\.city\.).*?(\.checked)\]").unwrap();
let string = ".city.playground[?(@.playhouse == 'true' && @.IsPoolAvailable=='true')].checked]
";
let substitution = "$1poolavailable$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}