import re
regex = re.compile(r"(\.city\.).*?(\.checked)\]", flags=re.MULTILINE)
test_str = (".city.playground[?(@.playhouse == 'true' && @.IsPoolAvailable=='true')].checked]\n")
subst = "$1poolavailable$2"
result = regex.sub(subst, test_str)
if result:
print(result)