const regex = /(\.city\.).*?(\.checked)\]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\.city\\.).*?(\\.checked)\\]', 'gm')
const str = `.city.playground[?(@.playhouse == 'true' && @.IsPoolAvailable=='true')].checked]
`;
const subst = `$1poolavailable$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);