import Foundation
let pattern = #"(\.city\.).*?(\.checked)\]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
.city.playground[?(@.playhouse == 'true' && @.IsPoolAvailable=='true')].checked]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1poolavailable$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)