use strict;
my $str = '.city.playground[?(@.playhouse == \'true\' && @.IsPoolAvailable==\'true\')].checked]
';
my $regex = qr/(\.city\.).*?(\.checked)\]/mp;
my $subst = '$1poolavailable$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";