package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\s*)hosts:.*`)
var str = `# Configure what output to use when sending the data collected by the beat.
#-------------------------- Elasticsearch output ------------------------------
output.elasticsearch:
# Array of hosts to connect to.
hosts: ["**ELASTICHOSTS**"]`
var substitution = "\1hosts: Db.es-dev.com:9200"
fmt.Println(re.ReplaceAllString(str, substitution))
}