import Foundation
let pattern = #"^(\s*)hosts:.*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
# Configure what output to use when sending the data collected by the beat.
#-------------------------- Elasticsearch output ------------------------------
output.elasticsearch:
# Array of hosts to connect to.
hosts: ["**ELASTICHOSTS**"]
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1hosts: Db.es-dev.com:9200"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)