$re = '/^(\s*)hosts:.*/m';
$str = '# Configure what output to use when sending the data collected by the beat.
#-------------------------- Elasticsearch output ------------------------------
output.elasticsearch:
# Array of hosts to connect to.
hosts: ["**ELASTICHOSTS**"]';
$subst = "\1hosts: Db.es-dev.com:9200";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;