const regex = new RegExp('^(\\s*)hosts:.*', 'gm')
const str = `# Configure what output to use when sending the data collected by the beat.
#-------------------------- Elasticsearch output ------------------------------
output.elasticsearch:
# Array of hosts to connect to.
hosts: ["**ELASTICHOSTS**"]`;
const subst = `\1hosts: Db.es-dev.com:9200`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);