import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\s*)hosts:.*";
final String string = "# Configure what output to use when sending the data collected by the beat.\n"
+ " \n"
+ " #-------------------------- Elasticsearch output ------------------------------\n"
+ " output.elasticsearch:\n"
+ " # Array of hosts to connect to.\n"
+ " \n"
+ " hosts: [\"**ELASTICHOSTS**\"]";
final String subst = "\\1hosts: Db.es-dev.com:9200";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}