re = /^(\s*)hosts:.*/m
str = '# Configure what output to use when sending the data collected by the beat.
#-------------------------- Elasticsearch output ------------------------------
output.elasticsearch:
# Array of hosts to connect to.
hosts: ["**ELASTICHOSTS**"]'
subst = '\\1hosts: Db.es-dev.com:9200'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result