use strict;
my $str = '# Configure what output to use when sending the data collected by the beat.
#-------------------------- Elasticsearch output ------------------------------
output.elasticsearch:
# Array of hosts to connect to.
hosts: ["**ELASTICHOSTS**"]';
my $regex = qr/^(\s*)hosts:.*/mp;
my $subst = '\\1hosts: Db.es-dev.com:9200';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";