// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\s*)hosts:.*").unwrap();
let string = "# Configure what output to use when sending the data collected by the beat.
#-------------------------- Elasticsearch output ------------------------------
output.elasticsearch:
# Array of hosts to connect to.
hosts: [\"**ELASTICHOSTS**\"]";
let substitution = "\\1hosts: Db.es-dev.com:9200";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}