# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\d+(?:-\d+)?)\D*mmHg|./$1 /gm;t' <<< "The right eye remains stable with an IOP of 12mmHg. The readings obtained in December 2005 15mmHgwere not very high"