// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\d+(?:-\d+)?)\D*mmHg|.").unwrap();
let string = "The right eye remains stable with an IOP of 12mmHg. The readings obtained in December 2005 15mmHgwere not very high";
let substitution = "$1 ";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}