re = /(\d+(?:-\d+)?)\D*mmHg|./m
str = 'The right eye remains stable with an IOP of 12mmHg. The readings obtained in December 2005 15mmHgwere not very high'
subst = '$1 '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result