package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d+(?:-\d+)?)\D*mmHg|.`)
var str = `The right eye remains stable with an IOP of 12mmHg. The readings obtained in December 2005 15mmHgwere not very high`
var substitution = "$1 "
fmt.Println(re.ReplaceAllString(str, substitution))
}