import Foundation
let pattern = #"(\d+(?:-\d+)?)\D*mmHg|."#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"The right eye remains stable with an IOP of 12mmHg. The readings obtained in December 2005 15mmHgwere not very high"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1 "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)