#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\d+(?:-\d+)?)\D*mmHg|."
Local $sString = "The right eye remains stable with an IOP of 12mmHg. The readings obtained in December 2005 15mmHgwere not very high"
Local $sSubst = "$1 "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)