import re
regex = re.compile(r"(\d+(?:-\d+)?)\D*mmHg|.", flags=re.MULTILINE)
test_str = "The right eye remains stable with an IOP of 12mmHg. The readings obtained in December 2005 15mmHgwere not very high"
subst = "$1 "
result = regex.sub(subst, test_str)
if result:
print(result)