const regex = /(\d+(?:-\d+)?)\D*mmHg|./gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+(?:-\\d+)?)\\D*mmHg|.', 'gm')
const str = `The right eye remains stable with an IOP of 12mmHg. The readings obtained in December 2005 15mmHgwere not very high`;
const subst = `$1 `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);