use strict;
my $str = 'The right eye remains stable with an IOP of 12mmHg. The readings obtained in December 2005 15mmHgwere not very high';
my $regex = qr/(\d+(?:-\d+)?)\D*mmHg|./mp;
my $subst = '$1 ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";