using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d+(?:-\d+)?)\D*mmHg|.";
string substitution = @"$1 ";
string input = @"The right eye remains stable with an IOP of 12mmHg. The readings obtained in December 2005 15mmHgwere not very high";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}