$re = '/(\d+(?:-\d+)?)\D*mmHg|./m';
$str = 'The right eye remains stable with an IOP of 12mmHg. The readings obtained in December 2005 15mmHgwere not very high';
$subst = "$1 ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;