# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b(?:(\d)|(\d{2}))\\/(?:(\d)|(\d{2}))\\/(?:(\d{2})|(\d{4}))\b/${5:+20$5:$6}-${1:+0$1:$2}-${3:+0$3:$4}/g;t' <<< "3/26/24
11/26/24
1/2/03
4/05/2006"