#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\b(?:(\d)|(\d{2}))\/(?:(\d)|(\d{2}))\/(?:(\d{2})|(\d{4}))\b"
Local $sString = "3/26/24" & @CRLF & _
"11/26/24" & @CRLF & _
"1/2/03" & @CRLF & _
"4/05/2006"
Local $sSubst = "${5:+20$5:$6}-${1:+0$1:$2}-${3:+0$3:$4}"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)