using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?:(\d)|(\d{2}))\/(?:(\d)|(\d{2}))\/(?:(\d{2})|(\d{4}))\b";
string substitution = @"${5:+20$5:$6}-${1:+0$1:$2}-${3:+0$3:$4}";
string input = @"3/26/24
11/26/24
1/2/03
4/05/2006";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}